从 Photo Mechanic 迁移到 Cullibrate 时可参考本指南。它介绍 Photo Mechanic 键盘预设、Photo Mechanic 导入设置与 Cullibrate 导入的对应关系,以及哪些 XMP 元数据会保留。
使用 Photo Mechanic 键盘预设
首次启动时,在“Cullibrate 应该使用哪套快捷键?”下选择 Photo Mechanic。这也会将 Cullibrate 切换到“工作台”外观。

已经完成设置?在偏好设置中应用同一预设:
- 打开偏好设置(Windows 上为设置),然后选择键盘。
- 在“带上你熟悉的快捷键”下点击“应用其他应用的预设”,然后选择 Photo Mechanic。
- 查看与当前配置文件的差异,然后点击“应用预设”。Cullibrate 会创建一个名为 Photo Mechanic 的键盘配置文件并切换到该配置文件。

该预设会更改以下按键分配:
- Space / V — 胶片栏(预览) / 比较
- C / Z / I — 裁剪 / 预览缩放 / 信息
- ← / → — 上一张 / 下一张照片
- 0–5 — 清除或设置颜色标签
- Ctrl0–Ctrl5 on Mac / Shift0–Shift5 on Windows — 清除或设置星级
- T — 切换标签
- 拒绝和清除保留 Cullibrate 的默认设置:X 用于拒绝,ShiftU 用于清除标记或拒绝。
- Photo Mechanic 有八种颜色类别,Cullibrate 有五种颜色标签,因此颜色类别 6 到 8 没有对应项。
- 如果预设需要某个 Cullibrate 快捷键所用的按键,该快捷键会移到附近的替代按键。审阅步骤会在应用前列出每项移动。
- 某些视图会保留自己的空格键操作:在网格中选中多张照片时,空格键会打开评比;在视频中则用于播放或暂停。
Photo Mechanic 导入与 Cullibrate 的对应关系
从“文件 → 新复制/导入”开始,或在插入存储卡时从“检测到存储卡”提示开始。选择“拷贝并筛选”即可复制照片,并在复制继续时开始审阅。

| Photo Mechanic | Cullibrate |
|---|---|
| 从多张存储卡导入 | 在同一次导入中选择多张存储卡 |
| Incremental Ingest | 仅新照片,跳过已从该存储卡导入的文件 |
| 主目标和次目标 | 目标位置和备份目标 |
| 目标文件夹变量 | 放置位置,由 YYYY、MM、DD、YYYYMMDD、YYYY-MM-DD、任务名称和自定义文本组成 |
| 使用变量和序号重命名 | 重命名,可加入原始名称和序号 |
| 保留文件夹层级 | 保留文件夹:用于区分照片的文件夹,或所有子文件夹 |
| 导入时的 IPTC 模板 | 元数据模板:创作者、版权、说明和关键词 |
Cullibrate 的模式由部件组合而成,而不是手动输入的变量。{filenamebase} 等 Photo Mechanic 变量或 IPTC 字段变量无法识别,因此请用对应的部件重新创建每个模板,并保存为模式供以后导入使用。
- 日期使用每张照片的拍摄日期,或整个导入共用一个日期。
- 原始名称和序号只能用于文件名,不能用于文件夹名称。
- 复制绝不会覆盖现有文件。相同的文件会被跳过;如有任何差异,照片会以新后缀复制。
- 开启“验证”可在应用元数据前逐字节检查每个副本。
XMP 兼容性
Cullibrate 在导入照片时读取 XMP,并将你的更改写回 XMP。RAW 文件使用照片旁边的附属文件;独立的 JPEG 和 DNG 文件将 XMP 保存在文件内部。
| 元数据 | 来自 Photo Mechanic | 由 Cullibrate 写入 |
|---|---|---|
| 星级评分 | 读取 | 写入 |
| 名为 Red、Yellow、Green、Blue 或 Purple 的颜色标签 | 读取 | 写入 |
| 其他颜色类别名称 | 忽略 | 不写入 |
| Tagged | 不读取 | 以 Lightroom 选取格式写入 |
| 已拒绝 | Photo Mechanic 中无对应项 | 以 Lightroom 拒绝格式写入 |
| 创作者和版权 | 读取 | 在导入时以及通过“编辑 → 编辑创建者和版权…”写入 |
| 说明和关键词 | 读取 | 仅在导入时写入 |
只有当 Photo Mechanic 的颜色类别使用这些名称时,它才会写入 Red、Yellow、Green、Blue 和 Purple。Camera Bits 在 Photo Mechanic 的偏好设置中为此提供了 Lightroom Classic 预设。Photo Mechanic 将 Tagged 存储在自己的 XMP 字段中,Cullibrate 不读取该字段。
如果导入后在 Photo Mechanic 中更改了评分或颜色标签,请先在 Photo Mechanic 中保存,然后在 Cullibrate 中选择“文件 → 重新同步外部 XMP 更改…”。

Cullibrate 不能替代的功能
Cullibrate 专注于导入和照片审阅。以下 Photo Mechanic 工具目前在 Cullibrate 中没有对应功能:
- 代码替换(Code Replacements)
- 完整的 IPTC 模板。导入模板涵盖创作者、版权、说明和关键词;之后可通过“编辑 → 编辑创建者和版权…”更改创作者和版权。
- 导入后编辑说明和关键词(暂未支持)
- FTP 上传
- 打印联系表
- 从监视文件夹进行 Live Ingest